[logback-dev] [JIRA] Created: (LBCLASSIC-102) Suggestion: Change logger name of inner classes.

Joern Huxhorn (JIRA) noreply-jira at qos.ch
Wed Jan 7 15:04:38 CET 2009

Suggestion: Change logger name of inner classes.

                 Key: LBCLASSIC-102
                 URL: http://jira.qos.ch/browse/LBCLASSIC-102
             Project: logback-classic
          Issue Type: Improvement
          Components: appender
    Affects Versions: 0.9.15
            Reporter: Joern Huxhorn
            Assignee: Logback dev list

At the moment, the logger name of inner classes is OuterClass$InnerClass.
Because of that, the logging level of OuterClass isn't inherited by InnerClass at the moment.

If LoggerFactory changed the logger name to OuterClass.InnerClass instead, InnerClass would inherit the logging level of OuterClass which seems intuitively correct.

I'd suggest to accept both $InnerClass and .InnerClass style in logback configurations for compatibility and usability reasons.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators: http://jira.qos.ch/secure/Administrators.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


More information about the logback-dev mailing list