[logback-dev] [JIRA] Commented: (LBCLASSIC-169) Customizing table names used by DbAppender

Greg Thomas (JIRA) noreply-jira at qos.ch
Wed Feb 24 15:19:16 CET 2010

    [ http://jira.qos.ch/browse/LBCLASSIC-169?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=11565#action_11565 ] 

Greg Thomas commented on LBCLASSIC-169:

I'm not so much interested in table/column names, but what I would like to see is the ability to record the individual values for the placeholders in the log message. 

If you're logging to a database, there's the possibility of running report on that database. Instead of having to parse out the data from the re-combined log message (e.g. "New call made; now 4 calls active"), it would be easier to record the value of arguments directly in the database. e.g. if you've configured it so that the first argument is stored in column arg1, and the second is stored in arg2, then the log entry 

logger.info( "New call made; now {} calls active", activeCallCount );

could appear in the database as (ignoring the other columns for this example) ...

formatted_message: "New call made; now 4 calls active"
arg1: "4"
arg2: null

> Customizing table names used by DbAppender
> ------------------------------------------
>                 Key: LBCLASSIC-169
>                 URL: http://jira.qos.ch/browse/LBCLASSIC-169
>             Project: logback-classic
>          Issue Type: Improvement
>          Components: appender
>    Affects Versions: 0.9.18
>            Reporter: Tomasz Nurkiewicz
>            Assignee: Logback dev list
>            Priority: Minor
> ch.qos.logback.classic.db.DBAppender uses hard-coded table names for logging events: logging_event, logging_event_property and logging_event_exception. Allowing to change these default names has two benefits:
> * There are systems where database table names must follow some naming conventions (prefixes, using underscores vs. camel case)
> * One could create several Db appenders, each operating on different set of tables (for performance reasons or more fine grained logging and filtering)
> Each table name would be configured using a property in logback.xml. Default values for table names would be the same as present ones to maintain backward compatibility. If you are interested in this feature let me know, I can implement it and provide a patch.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators: http://jira.qos.ch/secure/Administrators.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


More information about the logback-dev mailing list